• 周六. 10月 8th, 2022

5G编程聚合网

5G时代下一个聚合的编程学习网

热门标签

哪些个在 Sublime Text 下,"任性的" 好插件!

admin

11月 28, 2021

我在sublime里面安装了以下有利于项目开发高效的插件:

1:SVN             源代码版本控制

2:LiveReload   浏览器实时刷新 

3:jsMinifier     压缩 js [Ctrl+Alt+M] 或 [CtrL+Alt+Shift+M]

4:jsFormat      解压js插件

5:less2css (基于node环境安装)、less2css也需要安装、less(高亮)   函数式的css编程[Ctrl+S保存即可]

6:sass    sass build     函数式的css编程[Ctrl+B保存即可] 

此外还有诸如:emmet、git  等的好插件都是非常不错的。

下面是我安装的时候发现的一些报错问题,这些问题都找到并且解决了,我的系统是win8的。

1> jsMinifier   “Minifier Error: timed out“ 的问题

2> SASS [Ctrl+B]编译后报  “[Decode error – output not utf-8]“ 的问题

3> SVN 安装后报:sublime UnicodeEncodeError: ‘ascii’

     3.1> Sublime Text svn sftp 插件注册码 

————jsMinifier   “Minifier Error: timed out“ 的问题——————-

发现问题了, 在 compilers / googleclosurecall.py line 15
*.appspot.com 在中国访问是禁止的

解决方法:

1.找开 PackagesJsMinifierMinifier.sublime-settings
2.修改 compiler 的值为 ‘uglify_js’

————-SASS [Ctrl+B]编译后报  “[Decode error – output not utf-8]“ 的问题—————

首先确定你做了一下几步

 [1] you must install ruby  and sass

 [2] 在sublime里面,安装一个 sass build 插件,来集成编译 sass 文件, 很方便。

解决方法:我建议你照着这个来,用淘宝镜像代理去下载 ruby和sass ,这个才是终极的办法:

1:gem source –remove https://rubygems.org

2:gem source –a https://rubygems.org

3:  gem install sass

———————- SVN 安装后报:sublime UnicodeEncodeError: ‘ascii’————-

 呵呵,这个问题主要是有中文路径的问题所导致的报错。

解决方案: http://xg1990.com/blog/solve-win7-sublime-python-building-unicodeencodeerror/

解决方法如图:

 

sass  和 less 的重要的编译配置文件 

sass有两种后缀名文件:一种后缀名为sass,不使用大括号和分号;另一种就是我们这里使用的scss文件,这种和我们平时写的css文件格式差不多,使用大括号和分号.

sass语法 学习地址: http://www.w3cplus.com/sassguide/syntax.html

sasshat多米诺动画库: https://github.com/willian12345/sasshat

SASS Build 文件夹里面有个 SASS.sublime-build 文件,可以进行相应的配置,导出编译输出文件:

Less2css 文件夹里面有个 less2css.sublime-settings 文件,可以进行相应的配置,导出编译输出文件:

sass和less 编译后,都会在自动创建的css文件夹下面,如下图:

发表回复

您的电子邮箱地址不会被公开。